How to configure Chinese input (chewing ibus)?

Project:Linux software
Category:support request
Related pages:#209: Chinese :-:-: #232: Chinese input with ibus :-:-: #6216: LibreOffice :-:-: #9147: Chinese input :-:-: #9152: app-office/libreoffice

How to configure Chinese input (chewing ibus)?



I did:

sudo apt-get install ibus ibus-chewing

$ im-switch
eval: 1: zenity: not found
/usr/bin/im-switch: 501: zenity: not found


I could circumvent the error by installing zenity:
sudo apt-get install zenity
However, according to the im-switch changelog, zenity is not supposed to be necessary:

Superseded in natty-release on 2011-03-12
Published in maverick-release on 2010-09-09
im-switch (1.20ubuntu2) maverick; urgency=low

* Suggest not Depend on zenity, graphical functions are handled by
language-selector in Ubuntu and this brings in lots of unnecessary
bits into Kubuntu
-- Jonathan Riddell Thu, 09 Sep 2010 17:22:30 +0100


$ ibus-daemon &
$ current session already has an ibus-daemon.
[1]+  Exit 255                ibus-daemon
$ ibus-setup

Ibus seems to be running. I checked in the setup that CTRL+spacebar is supposed to change the input method, but it still doesn't work.


both ibus and ibus-kde do not work.

same problem as above poster.

ibus does not install itself as an option for the all_ALL quasi-locale



Try this:मातृभाषेत-लिहा/


It seems I had to reboot the computer to make all the changes effective. Login out of the session and login back in again was not enough. At least doing so does not restart the X server, which was apparently necessary after installing ibus.


Lightbulb Kubuntu 9.10: Get iBus working


uninstall ibus and ibus-chewing.
install synaptic.
reinstall ibus and ibus-chewing using synaptic, installing recommended packages.

+ ask TLUG about size of selection window and selection windows not appearing.


export GTK_IM_MODULE=ibus
export QT_IM_MODULE=ibus
export XMODIFIERS=@im=ibus


apt-get install ibus ibus-chewing ibus-qt4 ibus-gtk ibus-m17n

apt-get install ibus ibus-gtk ibus-qt4 plasma-widget-kimpanel-backend-ibus



[釋出派對]Ubuntu 11.04 Release Party in Taichung [論壇 - Ubuntu 與自由軟體相關活動版]


Some applications show the character selection window. Some don't. See attached images. (Note: in the screenshot, the application that shows the selection window is Konsole, and the one that doesn't is Konqueror)

Moreover, on another computer (fresh Kubuntu install) the character selection window never appears. This way, chewing is useless and we can't type Chinese.

Also, I changed the font size in ibus-setup , but it does not affect the size of the character selection window.

chewing1.png 12.66 KB
chewing2.png 24.66 KB


ibus-daemon -drx


I am testing the screenshot howto posted in the thread (link above) on another machine.

I am observing the following:
- the ibus daemon is not started in the new KDE session.
- I must start it manually within konsole, but then, konsole freezes for a while (a minute or so).
- only new konsoles or apps started after that will have ibus chewing enabled.
- the font is still not the right one (much too tiny)!
- instead of being automatically presented with the list of choices, I have to press the down arrow to see it (the key is not conveniently placed).
- I still haven't tested it with a second user (Ctrl+Alt+F8)


Strange. After I had done all the settings and tested everything for a while (and encountered the above issues), I re-visited the system language setting page and was told some packages were missing... I don't know which ones but I let the system install them automatically.

=> It didn't seem to help with anything, though.


I can't find where to install new input methods for Chinese (beside chewing).


PROBLEM: IBus doesn't start automatically when I restart my computer
Here is how I solved the problem:
Go to the menu:
System >> Preferences >> Startup Applications
Click the button: Add
Name: IBus daemon
Command: /usr/bin/ibus-daemon -d
Comment: start IBus daemon when Gnome starts


I removed ibus-qt4 and installed ibus-gtk.

Then I killed ibus-daemon and restarted ibus.


iBus and Traditional Chinese - a no hoper?


on blavatsky:

$ sudo apt-get install ibus-table-quick
Reading package lists... Done
Building dependency tree
Reading state information... Done.
The following extra packages will be installed:
ibus-table-quick-classic ibus-table-quick3 ibus-table-quick5
The following NEW packages will be installed:
ibus-table-quick ibus-table-quick-classic ibus-table-quick3 ibus-table-quick5


I don't know if it's the above apt-get install that changed anything, but now the font in the character selection window is as expected (very big, as set).

Cangjie works, but I cannot select with by clicking on it using the system tray applet. I need to use the keyboard shortcut.


Created (blavatsky)

export GTK_IM_MODULE=ibus
export XMODIFIERS=@im=ibus
export QT_IM_MODULE=ibus


echo "ibus-daemon -d -x -r -n kde" > $HOME/.kde/Autostart/ && chmod +x $HOME/.kde/Autostart/


Now Cangjie works but chewing stopped working altogether!!


What global/user configuration files affect ibus?

When changing fonts, when can we expect to see a change? Straight away or after the next reboot?
What are the conditions for the font change to take effect? (in other words, why it didn't work for the longest time for me).
Is this setting relevant to all input methods?

How can we have over-the-spot selection?


Interesting bug report:

gtkrc is not picked up by D-Bus-activated applications


re #29, I had to comment out the .xsessionrc settings as with it it broke chewing.

Now, it seems to work. It's all far from ideal, but it basically works.


After further testing, it seems that editing is not even necessary. I was used to the character selection window to appear automatically but it seems that in the new version, one has to press the down-arrow key in order to bring it up.

Actually, everything seems to be working... the major problem being a lack of documentation, both in Chinese and in English. Also, no extra configuration should be necessary on a system installed in Chinese.


Also, an important factor seems to be to select a language for which the input method has been set as being ibus-kde. If such is the case, ibus will be started automatically when starting the KDE session.

Extra configuration may be necessary when trying to configure ibus on an English system that is not configured to use ibus by default...


Related pages:+232: Chinese input with ibus


On Trouble's computer, the problem is that for some reason she had installed a cn keyboard layout, with a shortcut which interfered with ibus IM change shortcut. I removed the keyboard layout and all is fine.

I greated a 'guest' account and configured it properly, but ibus does not start automatically.


Hrrrgg... I am getting more and more confused.

Sometimes, the character selection window shows for each single character I type, sometimes I have the staging area and I must go back and press the down button to change the character....

Are those different behavior configurable??

[Edit: yes, it is. enable chewing and enter configuration page, and select: 單純注音末式.


Related pages:+9147: Chinese input


Related pages:+6216: LibreOffice, +9152: app-office/libreoffice