Many blocked packages with kdeplasma-addons

Project:Linux software
Component:Documentation
Category:support request
Priority:normal
Assigned:Unassigned
Status:fixed
Related pages:#9111: kde-plasma/kdeplasma-addons
Description

I'm not too sure about this:

$ emerge -a kde-plasma/kdeplasma-addons

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] net-libs/http-parser-2.6.2  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] dev-db/lmdb-0.9.18  USE="-static-libs"
[ebuild  N     ] dev-qt/qtpaths-5.6.1  USE="-debug {-test}"
[ebuild  N     ] media-fonts/noto-20160305-r1  USE="X cjk"
[ebuild  N     ] dev-libs/wayland-1.11.0  USE="-doc -static-libs" ABI_X86="32 (64) (-x32)"
[ebuild  N     ] dev-libs/libinput-1.4.2  USE="{-test}" INPUT_DEVICES="-wacom"
[ebuild  N     ] dev-qt/qdbus-5.6.1  USE="-debug {-test}"
[ebuild  N     ] dev-qt/qtgraphicaleffects-5.6.1  USE="-debug {-test}"
[ebuild   R    ] media-libs/mesa-12.0.1  USE="wayland*"
[ebuild   R    ] app-text/poppler-0.45.0  USE="qt5*"
[ebuild  N     ] kde-frameworks/kidletime-5.26.0  USE="-debug"
[ebuild  N     ] kde-plasma/kdecoration-5.7.5  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/threadweaver-5.26.0  USE="-debug {-test}"
[ebuild  N     ] kde-apps/kholidays-16.04.3  USE="-debug {-test}"
[ebuild  N     ] kde-plasma/oxygen-fonts-5.4.3  USE="X"
[ebuild  N     ] kde-frameworks/breeze-icons-5.26.0  USE="{-test}"
[ebuild  N     ] dev-qt/qtwayland-5.6.1  USE="xcomposite -debug -egl -qml {-test} -wayland-compositor"
[ebuild  N     ] dev-libs/libgit2-0.24.2  USE="threads -examples -gssapi (-libressl) -ssh {-test} -trace"
[ebuild  N     ] kde-frameworks/kwayland-5.26.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/kjsembed-5.26.0  USE="-debug"
[ebuild  N     ] kde-frameworks/kfilemetadata-5.26.0-r1  USE="exif ffmpeg pdf -debug -epub -libav -taglib {-test}"
[ebuild  N     ] kde-frameworks/frameworkintegration-5.26.0  USE="X -debug {-test}"
[ebuild  N     ] kde-frameworks/baloo-5.26.0-r2  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/kxmlrpcclient-5.26.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/knotifyconfig-5.26.0  USE="phonon -debug"
[ebuild  N     ] kde-frameworks/kross-5.26.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/ktexteditor-5.26.0-r2  USE="git -debug {-test}"
[ebuild  N     ] kde-frameworks/krunner-5.26.0  USE="-debug {-test}"
[ebuild  N     ] kde-plasma/libksysguard-5.7.5  USE="X detailedmemory -debug {-test}"
[ebuild  N     ] kde-plasma/ksysguard-5.7.5  USE="handbook lm_sensors -debug"
[ebuild  N     ] kde-plasma/milou-5.7.5  USE="-debug"
[ebuild  N     ] kde-plasma/breeze-5.7.5  USE="qt4 -debug -wayland"
[ebuild  N     ] kde-plasma/plasma-integration-5.7.5  USE="-debug {-test}"
[ebuild  N     ] kde-plasma/kscreenlocker-5.7.5  USE="pam -debug {-test}"
[uninstall     ] kde-base/kdebase-pam-10
[blocks b      ] kde-base/kdebase-pam:0 ("kde-base/kdebase-pam:0" is blocking kde-plasma/kscreenlocker-5.7.5)
[ebuild  N     ] kde-apps/kio-extras-16.04.3  USE="exif handbook phonon sftp -debug -mtp -openexr -samba -slp {-test}"
[uninstall     ] kde-plasma/kactivities-workspace-5.5.0
[blocks b      ] >kde-apps/kio-extras-15.12.50 (">kde-apps/kio-extras-15.12.50" is blocking kde-plasma/kactivities-workspace-5.5.0)
[ebuild  N     ] kde-plasma/kwin-5.7.5  USE="handbook -debug -gles2 -multimedia {-test}"
[uninstall     ] kde-base/kwin-4.11.22
[blocks b      ] kde-base/kwin:4 ("kde-base/kwin:4" is blocking kde-plasma/kwin-5.7.5)
[uninstall     ] kde-base/systemsettings-4.11.22-r2
[blocks b      ] kde-base/systemsettings:4 ("kde-base/systemsettings:4" is blocking kde-plasma/kwin-5.7.5)
[ebuild  N     ] kde-plasma/plasma-workspace-5.7.5  USE="calendar handbook -debug -geolocation -gps (-prison) -qalculate {-test}"
[uninstall     ] kde-base/ksmserver-4.11.22
[blocks b      ] kde-base/ksmserver:4 ("kde-base/ksmserver:4" is blocking kde-plasma/plasma-workspace-5.7.5)
[uninstall     ] kde-base/freespacenotifier-4.11.22
[blocks b      ] kde-base/freespacenotifier:4 ("kde-base/freespacenotifier:4" is blocking kde-plasma/plasma-workspace-5.7.5)
[uninstall     ] kde-base/kcminit-4.11.22
[blocks b      ] kde-base/kcminit:4 ("kde-base/kcminit:4" is blocking kde-plasma/plasma-workspace-5.7.5)
[uninstall     ] kde-base/ksplash-4.11.22
[blocks b      ] kde-base/ksplash:4 ("kde-base/ksplash:4" is blocking kde-plasma/plasma-workspace-5.7.5)
[uninstall     ] kde-base/klipper-4.11.22
[blocks b      ] kde-base/klipper:4 ("kde-base/klipper:4" is blocking kde-plasma/plasma-workspace-5.7.5)
[uninstall     ] kde-base/krunner-4.11.22
[blocks b      ] kde-base/krunner:4 ("kde-base/krunner:4" is blocking kde-plasma/plasma-workspace-5.7.5)
[uninstall     ] kde-base/plasma-workspace-4.11.22
[blocks b      ] kde-base/plasma-workspace:4 ("kde-base/plasma-workspace:4" is blocking kde-plasma/plasma-workspace-5.7.5)
[uninstall     ] kde-base/kdebase-startkde-4.11.22-r2
[blocks b      ] kde-base/kdebase-startkde:4 ("kde-base/kdebase-startkde:4" is blocking kde-plasma/plasma-workspace-5.7.5)
[ebuild  N     ] kde-plasma/kdeplasma-addons-5.7.5  USE="-debug -share"
[blocks B      ] kde-base/libtaskmanager:4 ("kde-base/libtaskmanager:4" is blocking kde-plasma/plasma-workspace-5.7.5)
[blocks B      ] kde-base/ksysguard:4 ("kde-base/ksysguard:4" is blocking kde-plasma/libksysguard-5.7.5, kde-plasma/ksysguard-5.7.5)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

  (kde-base/libtaskmanager-4.11.22:4/4.11::gentoo, installed) pulled in by
    >=kde-base/libtaskmanager-4.4:4[aqua=] (>=kde-base/libtaskmanager-4.4:4[-aqua]) required by (net-p2p/ktorrent-4.3.1-r1:4/4::gentoo, installed)

  (kde-plasma/plasma-workspace-5.7.5:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-plasma/plasma-workspace-5.7.5:5 required by (kde-plasma/kdeplasma-addons-5.7.5:5/5::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packag... following USE changes are necessary to proceed:
(see "package.use" in the portage(5) man page for more details)
# required by kde-plasma/kwin-5.7.5::gentoo
# required by kde-plasma/plasma-workspace-5.7.5::gentoo
# required by kde-plasma/kdeplasma-addons-5.7.5::gentoo
# required by kde-plasma/kdeplasma-addons (argument)
>=media-libs/mesa-12.0.1 wayland
# required by media-libs/mesa-12.0.1::gentoo[wayland]
# required by dev-qt/qtwayland-5.6.1::gentoo
# required by kde-frameworks/kwayland-5.26.0::gentoo
# required by kde-plasma/kscreenlocker-5.7.5::gentoo
# required by kde-plasma/plasma-workspace-5.7.5::gentoo
# required by kde-plasma/kdeplasma-addons-5.7.5::gentoo
# required by kde-plasma/kdeplasma-addons (argument)
>=dev-libs/wayland-1.11.0 abi_x86_32
# required by kde-frameworks/kfilemetadata-5.26.0-r1::gentoo[pdf]
# required by kde-frameworks/baloo-5.26.0-r2::gentoo
# required by kde-plasma/plasma-workspace-5.7.5::gentoo
# required by kde-plasma/kdeplasma-addons-5.7.5::gentoo
# required by kde-plasma/kdeplasma-addons (argument)
>=app-text/poppler-0.45.0 qt5

Would you like to add these changes to your config files? [Yes/No] n

emerge: there are no ebuilds built with USE flags to satisfy ">=dev-libs/wayland-1.2.0:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]".                                                                                             
!!! One of the following packages is required to complete your request:
- dev-libs/wayland-1.9.0::gentoo (Change USE: +abi_x86_32)
- media-libs/mesa-12.0.1::gentoo (Change USE: -abi_x86_32)
(dependency required by "media-libs/mesa-12.0.1::gentoo" [ebuild])
(dependency required by "dev-util/android-studio-2.1.2.0.143.2915827::gentoo" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

I'm not emerging now until I understand better what's at stake.

Comments

#1

Status:active» fixed

It was a conflict between KDE Plasma 4 and KDE Plasma 5.
Fixed by completely removing KDE 4 and installing KDE Plasma 5.