Firefox: ALSA and Pulseaudio

This is a wiki page. Be bold and improve it!

If you have any questions about the content on this page, don't hesitate to open a new ticket and we'll do our best to assist you.
USE=-pulseaudio : audio will not play without pulseaudio installed

ALSA support removed

In Firefox release 52, Mozilla disabled ALSA support by default and made Firefox default to Pulseaudio.

Within Gentoo, in an ALSA-only system (i.e. with the flag -pulseaudio), sound will not work in the pre-compiled binaries (www-client/firefox-bin) but it will work is you compile the full package yourself (www-client/firefox).